铁通ADSL用户注意了!

sucn| 阅读:2719 发表时间:2005-11-25 软件优选

近日BT 速度严重下降,原来180K/S以上的速度近日来降至20~50K/S,换了N个种子及不同的服务器均无改善,刚才在其它论坛发现一个贴子,才知道是铁通限了BT,立马打10050质询,接线女没有否认,只称BT消耗资源太大之类云云,偶一时火起,臭骂了一通挂了

没法玩了,明天上营业厅退订去!

铁通用户维护自己的权益的时候到了,请大家行动起来,一致抵制ISP恶意侵犯用户权益的无赖行为。

具体技术分析:(转贴)

铁通确实是封了100%种子的UDP数据报文

今天通过路由器节点侦侧,发现在CISCO铁通节点边缘路由上UDP被屏蔽,发现只要是100%(已经完成下载的种子,其实也是限制盗版的一个策略)的种子的数据UDP报文全部被屏蔽掉!其他的未达到100%的种子没有被屏蔽(其实暂时是存在技术性问题的),这个其实是很容易在节点路由器上实现的!大家也应该知道100%的种子才是下载某个文件的超级种子,他的上传和下载占用的带宽是最大的,运营商只要限制了100%的超级种子,数据的流量会明显下降!(但大家要问了,那为什么速度慢了,没有100%的种子了,为什么还可以下载完成呢?其实其他的种子还是可以连接到,但他们不是超级种子,速度肯定就很慢,到了后面,只要是下载完成一个----也就是达到100%《此时发送100%的报文》此时它的报文也就被屏蔽掉了,所以给大家的感觉是超级种子数量没有增加,始终是一个基本的接入速度,只是慢一些让你下载完成),其实他们干的很聪明,我也知道怎么用CISCO路由器去封BT还有EMULE,其实是:
用NBAR (Network-Based Application Recognition)网络应用识别
NBAR是一种动态能在四到七层寻找协议的技术,它不但能做到普通ACL能做到那样控制静态的TCP UDP的报,也能做到控制一般ACLs不能做到动态的端口的那些协议(如BT)之类.
An external Packet Description Language Module (PDLM)的文件用来扩展NBAR识别的协议。(具体我也翻译不出来,只看了个大概),
我就说说过程:
1到http://www.cisco.com/pcgi-bin/tablebuild.pl/pdlm 下载bittorrent.pdlm,(要CCO的)
2放到TFTP,然后用copy tftp disk2(大多数应该是flash)
#show runn
得到关于BT的部分是
class-map match-all bittorrent
match protocol bittorrent
!
!
policy-map bittorrent-policy
class bittorrent
drop
!
interface GigabitEthernet0/2
description CONNECT INSIDE
ip address 192.168.168.1 255.255.255.252 secondary
ip address 192.168.21.1 255.255.255.0
ip nat inside
service-policy input bittorrent-policy
service-policy output bittorrent-policy
duplex full
speed 1000
media-type rj45
no negotiation auto

这样的话,BT就不能下载,
下面是去掉EMULE的方法。
ip nbar pdlm bittorrent.pdlm
ip nbar pdlm eDonkey.pdlm

class-map match-any bittorrent
match protocol bittorrent
match protocol edonkey
!
!
policy-map bittorrent-policy
class bittorrent
drop
!
这样的话,Emule也能K掉了,

铁通还把上面的协议识别参数修改过了!我感觉这个大家都应该清楚!所以大家还是拿起法律武器告它单方面违约!我也是铁通用户,大家别扔砖头,我也和大家一样!
如果需要技术协议文件的话,我可以给大家整理出来!
总之一句话,他们是采用限制超级种子数量,来进行屏蔽,可他们还是有流量的,它也不是全部屏蔽掉了,给了大家一些低级种子,最后使下载文件的健康度始终达不到100%(其实也就是瞬间可能达到100%,但会马上屏蔽掉)这个给大家的感觉是比较迷惑的!也是他们的聪明之处!

*文章为原作者独立观点,不代表网站的立场
本文由网站发表并编辑,转载此文章须经作者同意,并请附上出处及本页链接。如有侵权,请联系本站删除。

友情连接